Partial Outage: Live Blog
Incident Report for Viafoura
Postmortem

Event Details

On May 11, 2021 it was observed that there were issues with our Social Ingestion service. The service was having problems connecting to its datastore. 

Incident Root Cause

It was determined that a code change had pulled an upstream breaking change from a library that disabled database connections on older versions of TLS.

Incident Impact

This was segregated to only users of the Social-Ingestion service and resulted in a one day downtime on the service during which time twitter feeds would not have updated.

Resolution Details

The code change was reverted and the service’s connection method was upgraded to a newer TLS method, which ultimately provides a higher level of security while simultaneously meeting SOC2 compliance standards. Additionally, the code change was rolled back.

Incident Prevention Action(s)

We are actively upgrading our TLS connection methods for any services that could encounter this change, this was the last remaining service to be changed. The code change will be retested to ensure no future outages.

Posted May 13, 2021 - 11:23 EDT

Resolved
The incident has been resolve, and Live Blog social ingestion functionality is back to normal
Posted May 13, 2021 - 09:38 EDT
Monitoring
A fix has been implemented and we are monitoring the Live Blog tools
Posted May 12, 2021 - 20:35 EDT
Identified
We are having issues with the Twitter social ingestion and are actively investigating
Posted May 12, 2021 - 17:29 EDT
This incident affected: Engagement tools.